Canon Programme DDP und EOS Utility ohne CD installieren

(Aktualisierung für Mountain Lion und DDP 3.13 im Anschluss)

Mit jeder Canon EOS Kamera wird eine CD ausgeliefert, welche so allerhand nützliche Tools beinhaltet. Diese Software ist im Lieferumfang einer Kamera zwar enthalten aber man kann sie nicht auf der Canon Homepage downloaden. Es sind nur Updates vorhanden, blöd also wenn man die CD verloren hat. Man kann aber auch den auf der Canon Homepage erhältlichen Updater dazu überreden eine Vollversion zu sein. Laden Sie sich zuerst das aktuelle Update von DDP oder EOS Utilty von der Canon Homepage herunter.

Die Updater sind im Prinzip Vollversionen, welche aber das Vorhandensein einer bereits installierten Vollversion prüfen. Die Prüfung kann man deaktivieren, in dem man im Paket die Datei »update.plist« löscht. Sie befindet sich in jedem Programm an einer anderen Stelle, also ggf danach suchen lassen.

Ein Problem ist im Vorfeld noch zu lösen; das Image (DMG) mit dem die Programme ausgeliefert werden ist read-only, zuerst muss daraus ein beschreibbares Image gemacht werden:

Sie können sich zuerst mal die Informationen des Images anzeigen lassen:

$ hdiutil imageinfo EU281X.dmg | head
Format Description: UDIF, nur lesen

Konvertieren Sie das Image in ein beschreibbares:

$ hdiutil convert EU281X.dmg -format UDSP -o EOS.sparseimage

Mounten Sie im Anschluss per Doppelklick das neue Sparseimage, navigieren Sie in das gemountete Image (hier im Beispiel heißt das gemountete Image »EU281X«, welches Sie prinzipiell im Ordner »/Volumes« finden und suchen Sie im Paket nach der Datei »update.plist«. Ignorieren Sie ggf auftretende Fehlermeldungen:

$ cd /Volumes/EU281X/
$ find . -name update.plist
find: ./.Trashes: Permission denied
./UpdateInstaller.app/Contents/Resources/SDI.bundle/Contents/Resources/update.plist

Löschen Sie die Datei update.plist:

$ rm -f ./UpdateInstaller.app/Contents/Resources/SDI.bundle/Contents/Resources/update.plist

Danach sollten Sie das Paket wie eine normale Vollversion installieren können. Verfahren Sie mit den anderen Programmen ebenso.

pronto 2010/10/01 16:36

DDP Version ≥ 3.13

Canon hat die Datei »update.plist« durch die Datei »Info.datx« (./DPP3.13.0/DPP3.13.0X_updater.app/Contents/Resources/Info.datx) ersetzt. Entfernen Sie diese Datei anstelle der »Update.plist« und Sie können den Installer im Anschluss ebenfalls wie eine Vollversion installieren.

pronto 2013/08/06 21:05

~~DISCUSSION~~

mac/install_dpp.txt (14515 views) · Zuletzt geändert: 2016/11/03 16:25 von pronto
CC Attribution-Share Alike 3.0 Unported
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0