Manuelle Installation eines Treibers

Problem: Bei einem ESXi 5.1 Host waren nach der Installation eines Patches keine Datastores mehr verfügbar. Es scheint eventuell an der Konstellation gelegen zu haben, dass der Speichercontroller nachträglich in das System eingebaut wurde und zwar das HP customized Betriebssystem einen Treiber für den »Smart Array Controller P830« zur Verfügung stellte aber der Patch1) von VMware selbst diesen Controller nicht berücksichtigte.

Lösung: Installieren Sie den Treiber für den HP Smart Array Controller P830 manuell. Laden Sie sich den passenden Treiber für Ihr Release von der VMware Seite2) herunter, entpacken ihn und kopieren Sie das »Vib« File zB nach »/tmp« auf dem ESXi Host:

$ scp ~/Downloads/hpsa-5.0.0.84-2338308/scsi-hpsa-5.0.0.84-1OEM.500.0.0.472560.x86_64.vib root@192.168.1.1:/tmp

Melden Sie sich mit einer SSH-Konsole auf dem ESXi Host an und installieren Sie den Treiber:

# esxcli software vib install --maintenance-mode --no-sig-check -v "/tmp/scsi-hpsa-5.0.0.84-1OEM.500.0.0.472560.x86_64.vib"

Bei erfolgreicher Installation wird Ihnen eine Zusammenfassung angezeigt:

Installation Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: Hewlett-Packard_bootbank_scsi-hpsa_5.0.0.84-1OEM.500.0.0.472560
   VIBs Removed: VMware_bootbank_scsi-hpsa_5.0.0-21vmw.510.1.16.1157734
   VIBs Skipped:

Starten Sie das System neu:

# reboot

Melden Sie sich erneut mit einer Konsole an und überprüfen Sie ob das System den Maintenance Mode wieder verlassen hat:

# vim-cmd /hostsvc/hostsummary | grep inMaintenanceMode
      inMaintenanceMode = false, 

Überprüfen Sie im vSphere Client ob der vermisste Datastore wieder verfügbar ist.

All done

pronto 2015/09/25 10:31

vmware/install_driver.txt (1353 views) · Zuletzt geändert: 2015/09/25 10:50 von pronto
CC Attribution-Share Alike 3.0 Unported
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0